Resolved
Legacy SS API is struggling with Sunday morning load

Started
April 02, 2023 at 1:44 PM
Status
Resolved after 42 minutes

Impact

Partial outage
Affected
production.songselectapi.com (legacy SongSelect API)
  • Resolved
    Resolved

    This incident appears to be resolved.

  • Monitoring
    Monitoring

    The extra servers are helping and the API is usually responding, but performance is still poor as we are in the heaviest of Sunday morning load. Once again, this only impacts the legacy SS API, and the new API is performing well. Customers may download resources directly from SongSelect or upgrade partner software if it yet supports the new API.

  • Investigating
    Investigating

    This only affects the legacy SS API (the new API is working well). The fix we had put in place for the legacy SS API last week is working, but has apparently increased the need for system resources so we are increasing server instances and monitoring as they come online.