CCLI - SongSelect may be intermittently and briefly down for maintenance. – Incident details

All systems operational

This page is for CCLI Partners. If you are a church or school please contact CCLI customer support.

SongSelect may be intermittently and briefly down for maintenance.

Resolved
Under maintenance
Started 14 days agoLasted 9 minutes

Affected

songselect.ccli.com

Under maintenance from 5:35 PM to 5:44 PM

Updates
  • Resolved
    Resolved

    Maintenance has been completed.

  • Monitoring
    Monitoring

    We will keep downtime to a minimum.