Resolved
Some systems unresponsive due to AWS reported outage

Started
December 15, 2021 at 3:40 PM
Status
Resolved after 23 minutes

Impact

Partial outage
Affected
songselect.ccli.com
  • Resolved
    December 15, 2021 at 4:02 PM

    AWS resolved their issue and SongSelect is back up.

  • Monitoring
    December 15, 2021 at 3:40 PM

    Amazon Web Services (AWS) has reported a problem serving the West Coast, and this is impacting some CCLI applications. We are monitoring and awaiting AWS to respond.