Resolved
SongSelect API is returning errors to partner software

Started
April 25, 2021 at 1:39 PM
Status
Resolved after about 2 hours

Impact

Partial outage
Affected
production.songselectapi.com (legacy SongSelect API)
  • Resolved
    April 25, 2021 at 3:46 PM

    The SongSelect API is operating normally.

  • Investigating
    April 25, 2021 at 2:31 PM

    We are still seeing problems and are investigating further. SongSelect is running fine, so customers can download what they need directly from SongSelect until the API issue is resolved.

  • Resolved
    April 25, 2021 at 2:12 PM

    The issue appears to be resolved, but we will continue to monitor on further into the morning.

  • Monitoring
    April 25, 2021 at 1:52 PM

    We implemented a fix about 10 minutes ago and and are currently monitoring the result. The API is returning to normal response times.

  • Investigating
    April 25, 2021 at 1:39 PM

    We are currently investigating this incident.