CCLI - Generating PDF sheet music is failing intermittently in SongSelect and Partner API – Incident details

All systems operational

This page is for CCLI Partners. If you are a church or school please contact CCLI customer support.

Generating PDF sheet music is failing intermittently in SongSelect and Partner API

Resolved
Operational
Started about 1 month agoLasted 1 day

Affected

songselect.ccli.com

Partial outage from 4:30 AM to 2:01 PM, Operational from 2:01 PM to 7:06 PM, Partial outage from 7:06 PM to 9:56 PM, Operational from 9:56 PM to 3:16 PM

api.ccli.com

Operational from 4:30 AM to 3:24 PM, Partial outage from 3:24 PM to 4:29 PM, Operational from 4:29 PM to 7:06 PM, Partial outage from 7:06 PM to 9:56 PM, Operational from 9:56 PM to 3:16 PM

Updates
  • Resolved
    Resolved

    The system is stable. This incident has been marked resolved, but we will continue to monitor closely over the coming weeks.

  • Monitoring
    Monitoring

    Things seem to have stabilized since 11:20am Pacific Time and things have been operational since then. We are continuing to monitor closely.

  • Identified
    Identified

    As we are monitoring, the problem has returned so we are reopening this incident. We are working on a solution. This is now likely also affecting the ability for Partners to get chord sheets, and it is impacting SongSelect ability to view Lead and Vocal sheets.

  • Resolved
    Resolved

    We believe this incident is resolved, but we will continue to monitor over the coming days.

  • Monitoring
    Monitoring

    At the moment, the system appears to be operating normal again. We will continue to monitor.

  • Identified
    Identified

    Althought the partner API was not affected from the prior issue, we are now seeing some new issues with the partner API. We are working on it.

  • Update
    Update

    After significant investigation, it appears the partner API was NOT negatively affected by this. It only affected our SongSelect application.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We have identified the problem area and are working on a fix for this incident.

  • Investigating
    Investigating
    We are currently investigating this incident.