CCLI - Unable to sign into SongSelect – Incident details

All systems operational

This page is for CCLI Partners. If you are a church or school please contact CCLI customer support.

Unable to sign into SongSelect

Resolved
Major outage
Started about 1 year agoLasted 10 minutes

Affected

songselect.ccli.com

Major outage from 4:58 PM to 5:08 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.